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Introduction 

About this guide 

The CodeLoader Users Guide is for fire alarm technicians. It 
shows you how install and run CodeLoader, in order to upgrade 
the microcode in a QuickStart system. 

If you’re an experienced user of CodeLoader, follow the 
summary steps in the “Fast path” topic. If you’re new to 
CodeLoader, or just want more information, read the remaining 
topics in this guide. The topics are arranged in the correct order 
for you to perform the microcode upgrade. 

What is CodeLoader? 

CodeLoader is a utility program that downloads microcode to 
QuickStart control panels and annunciator panels. You install 
and run CodeLoader on your laptop. 

CodeLoader is always made available as part of an upgrade 
package. The package consists of the latest version of 
CodeLoader, plus the microcode it is designed to install. 

System requirements 

You should install CodeLoader on the laptop you use for the 
QuickStart Configuration Utility. It must meet the following 
requirements: 

• Pentium processor-based personal computer 
• 16 MB of RAM 
• Available USB or DB-9 COM port 
• Microsoft Windows 98/2000/ME/XP 
• CD-ROM drive or Internet connection 

You’ll also need a download cable, model PROGCABLE-1, for 
connecting your laptop to the QuickStart panels. This is the same 
cable you use to send the project database to a panel or 
annunciator. 
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Fast path 
If you’ve used CodeLoader before, or are an advanced computer 
user, you can follow these summary steps to install and run 
CodeLoader. 

To install and run CodeLoader: 

1. Install CodeLoader on your laptop. 

We suggest that you accept the default locations provided by 
the installation or setup program. 

2. Connect your laptop to the QuickStart system control panel. 

3. Upload the project database from the control panel to your 
laptop. 

To do this, start the QuickStart Configuration Utility, then 
choose Retrieve Database From Panel from the Tools menu. 

4. Run the CodeLoader utility at the control panel. 

CodeLoader will advise you whether or not you need to 
restore the database. 

5. Restore the database at the control panel, if required. 

If the QuickStart system has no remote annunciators, you 
have completed the process. If the system includes remote 
annunciators, perform the remaining steps. 

6. Connect your laptop to a remote annunciator. 

7. Run the CodeLoader utility at the remote annunciator. 

8. Restore the database at the remote annunciator, if required. 

9. Repeat steps 6 through 8 for each additional remote 
annunciator in the QuickStart system. 
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About CodeLoader 
Microcode is the operating software stored in each control panel 
and annunciator panel. Microcode tells the panel how to operate 
and how to interpret the project database. Enhancements to 
QuickStart often require upgrades to the microcode. 

CodeLoader is a utility program that downloads revised 
microcode to QuickStart control panels and remote annunciators. 

CodeLoader is installed and runs on your laptop. You connect 
your laptop to a QuickStart control panel or remote annunciator, 
then run CodeLoader to download the revised microcode to the 
CPU of that panel or annunciator. 

CodeLoader is always part of an upgrade package. The upgrade 
package consists of the latest version of CodeLoader plus the 
revised microcode. 

Not all upgrades to the QuickStart Configuration Utility require 
a corresponding microcode upgrade. When you need to upgrade 
your microcode using CodeLoader, you’ll be notified in a 
Marketing Bulletin or Technical Fax. 
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Installing CodeLoader 
 

 1. Install CodeLoader on your laptop. 

 2. Connect your laptop to the control panel. 

 3. Upload the project database to your laptop. 

 4. Run CodeLoader at the control panel. 

 5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

There are two ways to install CodeLoader. First, you can run the 
setup program included on the QuickStart Upgrade CD. Second, 
you may be able to download and run a self-extracting upgrade 
package from your company web site (if one is available). 

CodeLoader is distributed as part of an upgrade package. The 
package consists of the latest version of CodeLoader, plus the 
revised microcode it is designed to install. 

When installing, we suggest that you accept the default locations 
provided by the installation or setup program. 

Upgrade CD 

The CD includes a setup program that installs the upgrade 
package on your laptop. The setup program runs automatically 
when you insert the CD in your CD-ROM drive. 

If you have AutoPlay disabled, you can use Windows Explorer 
to open the CD, then open Setup.exe. You don’t need to uninstall 
previous versions of CodeLoader before installing a new version. 

When the setup program begins, use the default choices offered 
in each dialog box to place the utility and microcode in the 
correct directories. 
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Web site 

Log on to your company web site and check the download area 
for the upgrade package. 

When downloading, you can save the upgrade package anywhere 
on your hard drive. You don’t need to uninstall previous versions 
of CodeLoader before installing a new version. 

Install the CodeLoader utility and microcode by opening the 
upgrade package you downloaded. 

When the setup program begins, use the default choices offered 
in each dialog box to place the utility and microcode in the 
correct directories. 
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Connecting your laptop to the panel 
 

1. Install CodeLoader on your laptop. 

 2. Connect your laptop to the control panel. 

 3. Upload the project database to your laptop. 

 4. Run CodeLoader at the control panel. 

 5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

You use the PROGCABLE-1 download cable to connect your 
laptop to the QuickStart control panel and remote annunciators. 
This is the same cable you use to send the project database to the 
panel or annunciator. 

The cable plugs into the DB-9 COM port on your laptop and the 
RJ-12 modular jack on the front of the QuickStart control panel 
or remote annunciator. 

You can connect using one of the USB ports on your laptop if 
you purchase and attach a “USB to Serial RS-232 DB-9 Adapter 
Cable.” 

Note: Whenever you connect your laptop to the RJ-12 jack, the 
panel reports a ground fault error. This message clears when you 
complete your work and unplug from the RJ-12 jack. 

Connect your laptop to the QuickStart control panel now. 
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Uploading the database 
 

1. Install CodeLoader on your laptop. 

2. Connect your laptop to the control panel. 

 3. Upload the project database to your laptop. 

 4. Run CodeLoader at the control panel. 

 5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

After most microcode upgrades, you’ll need to restore the project 
database by sending it from your laptop to the QuickStart control 
panel or remote annunciator panel. For this reason, you should 
verify that you have the latest version of the project database 
stored on your laptop before you run CodeLoader. 

The easiest way to do this is to upload (i.e. retrieve) the project 
database from the QuickStart control panel. You only need to 
upload the project database once, but you must do so from the 
control panel, not from a remote annunciator. 

We suggest that you retrieve the database into a new project on 
your laptop. 

To retrieve the database: 

1. Start the QuickStart Configuration Utility. 

2. Choose Project > New to create a new project. 

 The system displays the Project Configuration dialog box. 

3. Click Close. 

4. Choose Tools > Retrieve Database From Panel. 

 The system displays the Confirm dialog box, asking if you 
want to save the new project. 

5. Click No. 
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The system displays the Retrieving System Data dialog box. 

6. Verify the Port, Baud Rate and Cabinet Type settings. Select 
38400 as the baud rate. 

7. Verify that the laptop is connected to the control panel 
(Panel 01). 

8. Click OK to upload the database. 

The system displays the Communications Status dialog box 
while the transfer is in progress. 

9. Click OK to complete the retrieval process. 

10. Choose Project > Save. 

11. In the Project box, type the project name. 

12. In the Version boxes, type or select the version number. 

13. In the Description of Changes text box, enter a description 
that indicates the upgrade you’re making. 

For example: After CU Version 9.9 update and microcode 
upgrade. 
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Running CodeLoader 
 

1. Install CodeLoader on your laptop. 

2. Connect your laptop to the control panel. 

3. Upload the project database to your laptop. 

 4. Run CodeLoader at the control panel. 

 5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

Use CodeLoader to upgrade the QuickStart control panel 
microcode. If your system has remote annunciators, you must 
use CodeLoader to upgrade each remote annunciator as well. 
There is no way to upgrade across the network. 

Once you start the upgrade process and establish 
communication with the panel, do not disturb the computer or 
the system until the entire process is complete. 

The CodeLoader utility has built-in error recovery functions. In 
the event of an error it is important to follow the instructions 
provided in the error messages. Failure to follow these 
instructions could result in loss of database information. 

If you will need to restore the project database after the upgrade, 
CodeLoader displays the following message: 
Updating this version of microcode will result in 
loss of database information stored in the panel! Do 
you wish to proceed? 
If you see this message, check that you’ve uploaded the database 
before you click OK to continue. 

CodeLoader gives you the option to install an earlier version of 
the microcode if you wish. The latest version of microcode is 
selected as the default. Install the latest version unless instructed 
otherwise by our Technical Support staff. 
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To run CodeLoader: 

1. From the Windows Start menu, choose Programs > 
CodeLoader > [Version] > CodeLoader. 

2. Choose Setup > Port to configure your communications port. 

 Make sure the correct port is selected, and that the baud rate 
is set for 38400. Click OK to continue. 

3. Verify that the communications cable is properly connected 
to the control panel. 

4. Choose Communications > Update Microcode. 

5. Enter the Level 3 password and click OK to begin the 
upgrade. 

CodeLoader displays a dialog box that lets you select 
different versions of microcode. 

6. Click OK to select the latest version (the default). 

CodeLoader displays various information and confirmation 
messages. 

7. Click Yes to acknowledge the messages and continue. 

CodeLoader displays a Communications Status dialog box 
while the transfer is in progress. 

Note: Do not disturb the computer or the system until the 
upgrade is finished. If errors occur, be sure to follow the 
instructions provided with the error message. 

When the transfer is complete, CodeLoader displays a message 
to indicate that the code was transferred successfully 
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Restoring the project database 
 

1. Install CodeLoader on your laptop. 

2. Connect your laptop to the control panel. 

3. Upload the project database to your laptop. 

4. Run CodeLoader at the control panel. 

 5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

If you need to restore the project database, you’ll need to run the 
QuickStart Configuration Utility at the control panel. You’ll also 
need to restore the project database at each remote annunciator 
after you upgrade the annunciator microcode. 

There is no way restore the databases across the network. You 
cannot use Save and Sync to distribute a project database across 
a network. 

Note: The system will not function properly until the control 
panel and all remote annunciator panels have the current 
database. 

In the QuickStart Configuration Utility, you’ll be working with 
the Communications Selection dialog box. When you begin, 
make sure that the Selected check box is checked for each panel 
in the system. This will help you keep track of your progress. 

Upgrade the microcode then restore the database at each panel in 
sequence to ensure that no mistakes are made. Once the database 
has been sent to a panel, the system automatically clears the 
Selected check box for that panel. 

To restore the database to the control panel: 

1. Start the QuickStart Configuration Utility. 

2. Choose Project > Open and open the current project for the 
site. 
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3. Choose Tools > Send Database to Panel. 

 Make sure that the Port and Baud Rate settings are correct, 
and that you are connected to the first selected panel. 

4. Verify that the communications cable is properly connected 
to the control panel. 

5. Click Transmit Database to System to send the database to 
the panel. 

6. When the transmission is complete, disconnect your laptop 
from the control panel. 
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Upgrading the remote annunciators 
 

1. Install CodeLoader on your laptop. 

2. Connect your laptop to the control panel. 

3. Upload the project database to your laptop. 

4. Run CodeLoader at the control panel. 

5. Restore the database at the control panel, if required. 

 6. Connect your laptop to a remote annunciator. 

 7. Run CodeLoader at the remote annunciator. 

 8. Restore the database at the remote annunciator, if required. 

 9. Repeat steps 6 through 8 for each remote annunciator. 

 

If your QuickStart system includes remote annunciators, repeat 
the upgrade and restore process at each remote annunciator. 

Note: Whenever you connect your laptop to the RJ-12 jack, the 
panel reports a ground fault error. This message clears when you 
complete your work and unplug from the RJ-12 jack. 

To upgrade a remote annunciator 

1. Use the PROGCABLE-1 cable to connect your laptop to the 
QuickStart remote annunciator. 

2. From the Windows Start menu, choose Programs > 
CodeLoader > [Version] > CodeLoader. 

3. Choose Setup > Port to configure your communications port. 

 Make sure the correct port is selected, and that the baud rate 
is set for 38400. Click OK to continue. 

4. Choose Communications > Update Microcode. 

5. Enter the Level 3 password and click OK to begin the 
upgrade. 

CodeLoader displays a dialog box that lets you select 
different versions of microcode. 

6. Click OK to select the latest version (the default). 
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CodeLoader displays various information and confirmation 
messages. 

7. Click Yes to acknowledge the messages and continue. 

CodeLoader displays a Communications Status dialog box 
while the transfer is in progress. 

Note: Do not disturb the computer or the system until the 
upgrade is finished. If errors occur, be sure to follow the 
instructions provided with the error message. 

When the transfer is complete, CodeLoader displays a message 
to indicate that the code was transferred successfully. 

To restore the database to a remote annunciator: 

1. Start the QuickStart Configuration Utility. 

2. Choose Project > Open and open the current project for the 
site. 

3. Choose Tools > Send Database to Panel. 

 Make sure that the Port and Baud Rate settings are correct, 
and that you are connected to the next selected panel. 

4. Click Transmit Database to System to send the database to 
the panel. 

The system may display a warning message indicating that 
you are connected to Panel 01. This is because the old 
database was destroyed and the correct panel number was 
lost. 

5. Verify that you are connected to the correct panel, then click 
Yes to allow the transfer. 

6. When the transmission is complete, disconnect your laptop 
from the remote annunciator. 
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Glossary 

AutoPlay: A Microsoft Windows operating system feature that 
monitors a CD-ROM drive, and attempts to launch the 
appropriate program when a CD is inserted. 

CodeLoader: The program used to download revised microcode 
to a QuickStart control panel CPU or remote annunciator 
CPU. 

Configuration Utility: The program used to create or revise a 
project database, and thus to program the features and 
functions of a QuickStart system. 

control panel: A QuickStart system has a single control panel, 
designated as Panel 01. It can have any number of 
remote annunciator panels. 

database: The QuickStart project database. See also project 
database. 

DB-9 COM: A type of RS-232 communications port used on 
computers. The port uses a male DB-9 connector. Newer 
model laptops may not have a DB-9 COM port, and may 
require the use of a “USB to Serial RS-232 DB-9 
Adapter Cable.” 

microcode: Low-level code that defines how a processor 
operates. Microcode tells a control panel or remote 
annunciator CPU how to operate and how to interpret 
the project database. 

network: A QuickStart system with a control panel and one or 
more remote annunciators is called a network. Event 
messages and control commands can be passed across 
the network. However, the project database and panel 
microcode cannot be transmitted across the network, but 
must be downloaded at the panel and each annunciator. 

port: Serial communication ports are designated as COM1, 
COM2, etc. You must choose the port that is assigned to 
the DB-9 connector by your laptop configuration. This is 
normally COM1. 
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PROGCABLE-1: A cable used to connect a laptop to a 
QuickStart control panel or remote annunciator. One end 
connects to the DB-9 COM port of the laptop. the other 
end connects to the RJ-12 modular plug on the front of 
the control panel or remote annunciator. 

project database: A set of information created by the 
QuickStart Configuration Utility. The project database is 
downloaded to the QuickStart control panel and remote 
annunciators to program the features and functions of the 
system. 

remote annunciator: A panel with programmed annunciation 
and control functions. A QuickStart system can have any 
number of remote annunciator panels, starting with 
Panel 02. 

restore: To transmit the project database from a laptop to the 
QuickStart control panel or remote annunciator, using 
the Send Database To Panel command of the QuickStart 
Configuration Utility. 

RJ-12 modular jack: The square connector located behind a 
removable plastic insert on the front face of QuickStart 
control panels and remote annunciators. This jack is 
used for connecting the panel to a laptop. 

self-extracting: A compressed upgrade package that can be run 
like any program. It expands and installs the required 
files when it runs. 

upgrade package: CodeLoader is distributed as part of an 
upgrade package. The package consists of a given 
version of CodeLoader and the revised microcode it is 
designed to install. 

upload: To transmit the project database from the QuickStart 
control panel to a laptop, using the Retrieve Database 
From Panel command of the QuickStart Configuration 
Utility. 
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