
© 2022 Carrier 1 / 24 P/N 270729-EN • REV 022 • ISS 22FEB22 

 

3-SDU V5.46 Release Notes 

Content 
Introduction   1 
Operating system compatibility   1 
Changes in this version   2 
Language support   2 
Bilingual language character sets (for EST3 control unit only projects)   4 
Printer code pages   4 
Software versions and compatibility   5 
Installing and upgrading to 3-SDU 5.46   7 
Upgrading microcode versions   13 
Important information   16 
Reminder of NFPA 72 testing requirements   17 
Known issues   17 
 

Introduction 
These release notes document the changes in 3-SDU version 5.46. Please read these release notes in their 
entirety before installing 3-SDU 5.46.  

We may use “x” in a model number to indicate several generations of the product. For example, 3-CPUx 
represents the 3-CPU, 3-CPU1, and 3-CPU3. 

Contacting support 
Contact technical support if you encounter any difficulties during this installation. 

Tel  +1 800 655 4497 
Technical Support Ticket 
www.edwardsfiresafety.com 

Operating system compatibility 
3-SDU 5.46 is compatible with the following versions of Microsoft Windows: 

• Windows 7 Professional SP1 (32-bit) 

• Windows 7 Professional SP1 (64-bit) 

• Windows 8.1 Professional (32-bit) 

• Windows 8.1 Professional (64-bit) 

https://myeddie.edwardsfiresafety.com/Login/Login?Support=Edwards
http://www.edwardsfiresafety.com/
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• Windows 10 Home, version 20H1 (32-bit) 

• Windows 10 Home, version 20H1 (64-bit) 

• Windows 10 Professional, version 20H1 (32-bit) 

• Windows 10 Professional, version 20H1 (64-bit) 

• Windows 10 Professional N (32-bit) 

• Windows 10 Professional N (64-bit) 

Note: 3-SDU 5.46 must be “run as administrator,” and requires full elevated rights and privileges. 

Changes in this version 
New features and updates in this release include: 

• Support for 3-SAC LRM for European marketplace configurations  

Language support 
Table 1 below and Table 2 on page 3 detail the language support available in 3-SDU version 5.46. 

Table 1: Language support on projects containing EST3 control units only  
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Arabic 
(United Arab Emirates)          

X   

Chinese 
(Simplified PRC)      X   

   X 

Chinese 
(Traditional Taiwan)            X 

Dutch 
(Standard - Netherlands)   X          

English 
(Australia)     X    X    

English  
(Britain)   X     X     

English 
(USA) X X X X  X X  X X X X 

Finnish 
(Finland)   X          

French 
(Canada) X X         X  
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French  
(France)   X          

German 
(Standard - Germany)   X          

Hebrew 
(Israel) X   X       X  

Italian 
(Italy) X  X        X  

Korean  
(Extended Wansung - Korea)            X 

Polish 
(Poland)   X          

Portuguese 
(Brazil) X          X  

Portuguese 
(Standard - Portugal)   X          

Russian 
(Russia) X  X        X  

Slovak 
(Slovakia)   X          

Spanish 
(Mexico) X          X  

Spanish 
(Modern Sort - Spain)   X          

Turkish 
(Turkey) X  X        X  

Table 2: Language support on projects containing EST3X control units  
only, or a combination of EST3X and EST3 control units 
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English (USA) X X 

French (Canada) X X 

Portuguese (Brazil) X  

Spanish (Mexico) X  
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Note: The KPDISP provides a single layout for use in the markets and languages served by the American, 
European, Middle East, and Australian market places. 

Bilingual language character sets (for EST3 control unit only projects) 
When selecting a primary and secondary language, both languages must be supported in the same font table. 

Table 3: Bilingual character sets 

EST3 code page Bilingual language sets 

1250 (Eastern Europe) Croatian, Czech, English, Hungarian, Polish, Slovak 

1251 (Cyrillic) English, Russian 

1252 (Western Europe) Danish, Dutch, English, Finnish, French, German, Italian, Norwegian, 
Portuguese, Spanish, Swedish 

1254 (Turkish) English, Turkish 

1255 (Hebrew) English, Hebrew 
 

Note: When using English as one of the languages in a code page, it must be set as the secondary language on 
the Configure Project > Operations tab. The exception to this is the Western Europe code page, where English 
can be set as the secondary or the primary language. 

Printer code pages 
The following table shows the DOS code page support required to allow you to print in the local language. Since 
not all Windows characters are available on a DOS printer, some characters may not be supported. 

Table 4: Printer code pages 

EST3 code page Printer code page 

936 (Chinese Simplified) Windows Code Page 936 (GB) 

949 (Korean) Windows Code Page 949 (Extended Wansung) 

950 (Chinese Traditional ) Windows Code Page 950 (Big 5) 

1250 (Eastern Europe) DOS Code Page 852 

1251 (Cyrillic) DOS Code Page 866 

1252 (Western Europe)  DOS Code Page 850 

1254 (Turkish) DOS Code Page 857 

1255 (Hebrew) DOS Code Page 862 

1256 (Arabic UL) DOS Code Page 864 
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Software versions and compatibility 
LRM compatible versions 
You must upgrade all applicable microcode versions to take full advantage of the new features offered in  
3-SDU 5.46. 

Table 5: 3-SDU 5.46 software compatibility 

LRM Oldest version [1] Latest version Medium Part number 

3-ASU 3.01 3.50 Web 3-SDU 

3-AADC 3.41 3.41 Web 3-SDU 

3-AADC1 3.41 3.71 Web 3-SDU 

3-CPUx 3.65 5.30 Web 3-SDU 

3-EASC/3-EADC 3.61 4.0 Web 3-SDU 

3-FTCU 1.0 1.2 Chip 190156 

3-FTCU 1.4 3.4 Chip 190254 

3-IDC8/4 1.1 3.6 Chip 190159 

3-LDSM 1.0 5.0 Chip 190153 or 7350700 

3-MODCOM(P) 3.6 3.6 Web 3-SDU 

3-OPS 1.0 3.1 Chip 190158 or 7400158 

3-PPS 1.0 3.64 Chip 190157 or 7400152 

3-BPS 1.0 3.64 Chip 190157 or 7400152 

4-PPS/M TBD TBD Web TBD 

3-BBC 3.0 3.64 Chip 190157 or 7400152 

3-RS485-A/B - 1.51 PAL Chip 190271 

3-RS485-R - 1.4 PAL Chip 190270 

3-SSDC/3-SDDC 3.32 3.32 Web 3-SDU 

3-SSDC1/3-SDDC1 3.32 5.20 Web 3-SDU 

3-SSDC2/3-SDDC2 5.40 5.40 Web 3-SDU 

3-SAC 3.6 3.6 Web 3-SDU 

3-ZA15 1.1 [3] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA20A 1.4 3.64 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA20B 1.4 3.64 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 



P/N 270729-EN • REV 022 • ISS 22FEB22 6 / 24 

LRM Oldest version [1] Latest version Medium Part number 

3-ZA30 1.1 [3] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA40A 1.4 3.64 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA40B 1.4 3.64 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA90 1.4 N/A Chip 190252 

 1.4 N/A PAL Chip 190191 

3-ZA95 1.4 3.64 Chip 190252 

 1.0 1.0 PAL Chip 7400068 

C-CPU 1.07 1.40 Web 3-SDU 

CRC 1.7 1.7 Web 3-SDU 

KPDISP 1.6 1.6 Web 3-SDU 

CDR-3 2.0 3.6 Chip 190071 

RLCD 2.0 2.04 Chip RLCD 

RLCD-C 2.0 2.04 Chip RLCD-C 

RLED 2.0 2.04 Chip RLED 

GCI 2.0 2.04 Chip GCI 

[1] Oldest version still compatible with the current version of 3-SDU. 
[2] International and China markets only. 
[3] Version 1.12 required for stand-alone mode disabled feature. To obtain V1.12, request a deviation version for 
part number 190151 from Technical Support. 

Notes 

• All 3-CPUx control units on a network must use the same version of microcode. Networks with 3-CPU 
microcode version 3.0 or later can be upgraded with the 3-SDU by using the network download function. See 
“Upgrading microcode versions” on page 13. 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed on the same network as, 3-CPU1 
and 3-CPU.  

• 3-FTCU firmware comes in two non-interchangeable forms. Part 190254 cannot be used to update Part 
190156, and vice versa. 

3-SDU database compatibility 
Use 3-SDU 5.46 to generate databases for the LRMs listed in Table 6 below. 

Table 6: LRM microcode supported by 3-SDU 5.46 

LRM 3-SDU supported microcode versions 

3-AADC V3.41  
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LRM 3-SDU supported microcode versions 

3-AADC1 V3.41, V3.6, V3.7, V3.71 

3-ASU V3.01, V3.4, V3.5 

3-CPU V3.65, V3.75, V4.05, V5.02, V5.03, V5.20, V5.21, V5.30 

3-EADC/EADC V3.61, V4.0 

3-MODCOM(P) V3.6 

3-SAC V3.6 

3-SSDC/SDDC V3.32 

3-SSDC1/SDDC1 V3.32, V3.6, V3.7, V3.71, V3.75, V4.0, V4.02, V4.05, V4.10, V5.20 

3-SSDC2/SDDC2 V5.40 

4-PPS/M  TBD 

C-CPU V1.07, V1.11, V1.20, V1.30, V1.31, V1.40 

CRC V1.7 

KPDISP V1.6 

Installing and upgrading to 3-SDU 5.46 
Upgrading 
If previous 3-SDU versions are not uninstalled, you will be prompted during the new version installation to do so, 
or to choose a different directory for the new version.  

Note: As a best practice, always export and save all projects to a backup location before uninstalling the 3-SDU.  

The 3-SDU does not remove the Projects folder during the uninstall process; however, the location to which you 
install the new version affects the list of projects shown by 3-SDU 5.46.  

The location of the installation affects your projects as follows: 

• If you are installing into the same directory as the previous installation, the 3-SDU does not overwrite the old 
Projects folder, so your existing projects remain intact. When you open an existing project, the 3-SDU 
converts that project’s internal database format to work with 3-SDU 5.46.  

• If you are installing into a different directory than the previous installation, the Projects folder will be empty. 
Your old projects still exist in the Projects folder of your previous installation directory, but are not accessible 
from the V5.46 installation of the 3-SDU. To correct this, after you have finished upgrading to 3-SDU 5.46, 
import your existing projects from your backup location. 

Installation prerequisites 
When you start the initial 3-SDU installation, as well as consecutive installations, a requirements window (Figure 1 
on page 8) appears listing any prerequisites that need to be installed on your computer. An installation wizard will 
step you through installing the HASP device driver and Adobe Reader prerequisites. 
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Figure 1: The requirements window 

 

HASP device driver 
The HASP requirement only appears during a first-time installation. Any subsequent installations of the 3-SDU 
application do not display the HASP requirement. 

Note: The HASP does not uninstall if you uninstall the 3-SDU. If you need to uninstall the HASP, use the 
Windows Control Panel. 

Adobe Reader 
Whether upgrading or performing a new 3-SDU installation, the application will automatically install Adobe Reader 
if no previous version is installed. If a previous version is found, the application does not display the Adobe 
Reader requirement. 

Installing the 3-SDU 
The 3-SDU application begins installing immediately after the prerequisite requirements have installed completely. 

Note: To successfully install the application, the HASP key must be inserted in the USB port on the computer 
before starting the installation. 
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To install the 3-SDU: 
1. Double-click the 3-SDU setup.exe file. The prerequisites requirements window appears (see Figure 1 on page 

8). Click Install. 

If Adobe Reader is not found on the computer, an Adobe Reader installation window appears. Click Next, and 
then follow the on-screen instructions. 

 
The Sentinel Runtime Setup window appears, starting the HASP device driver installation process. Click 
Repair, click Next, and then click Next on the Ready to Repair window. 

Note: When installing the 3-SDU on top of or with an existing version, click Repair. Do not click Remove. 
Doing so removes the HASP driver but continues with the 3-SDU installation. You cannot use the 3-SDU 
without the HASP driver installed. 
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Click Finish to exit the HASP device driver installation. 

 
2. The 3-SDU installation wizard starts and displays the welcome page. Click Next. 
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3. The License Agreement page appears. Click Yes to accept the license. 

 
4. The Choose Destination Location page appears. Click Browse to select another folder or click Next to choose 

the default path C:\FAST\3-SDU\. 
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5. The Ready to Install page appears. Click Install to begin transferring files. 

 
6. The Borland Database Engine (BDE) installation automatically starts. 

Note: If the 3-SDU installation remains in wait mode, the Borland Database Engine Installation/Upgrade 
(BDE) dialog box may be behind the 3-SDU Installation window or other active window. When this happens, 
click the BDE icon in the Windows taskbar. See the next figure to locate the icon.  
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Note: The Borland Database Engine Installation/Upgrade dialog box appears. Do not click the Cancel button. 
Any attempt to cancel the BDE installation generates an error. 

 
You can click Browse to select another folder, or click OK to choose the default path C:\BDE. We do not 
recommend changing the default path.  

If the BDE is already installed in the default directory, it overwrites the previous installation. You can also 
install the BDE in multiple directories. Neither of these scenarios affects the operation of the 3-SDU 
application. 

7. After the BDE finishes installing, the Complete page appears. Click Finish to complete the 3-SDU installation. 

 

Upgrading microcode versions 
3-CPUx version 5.30 
Project version numbers are embedded in each project file. Because the Save As command creates a new 
version number that is different than the embedded version, you must use the following procedure to install V5.30. 
Please follow these steps in the correct order to upgrade the hardware and software in your system. 

Notes  

• When adding an EST3X fire alarm control unit to an EST3 Network, upgrade your EST3 microcode to V5.30 
before connecting EST3X nodes to the EST3 network. 

• Do not mix different versions of 3-CPUx microcode on the same network. Upgrade an existing system by 
carefully following this procedure. 
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To upgrade 3-CPUx V3.0 or later to V5.30: 
1. Install 3-SDU 5.46. 

2. Click Project > Open and select your project from the Open Project dialog box. Click OK to open the project. 

Note: When you open a project, the 3-SDU may give you a warning that states “Some or all of this project’s 
selected Microcode versions do not exist or are incompatible with the Brand or Market place. Click OK to 
update to the latest versions or click Ignore and fix the problem manually.” If you click Ignore and do not 
select valid versions of microcode, errors can occur when configuring the LRMs. Therefore, if you click Ignore, 
also go to the Project Parameters > Microcode tab and verify that the selected microcode versions are all 
supported; the 3-SDU highlights in red those versions that are no longer supported. 

3. Click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop controllers and cabinets. 

7. Click Project > Save to save the recompiled project. 

8. Click Tools > Communications and select Network for the Download mode. 

9. From the LRM Type Display Filter group, select 3-CPU. From the File Display Filter group, select three 
options, Boot loader code, Application code, and Database for each control unit. (Do not select any other 
option.) 

10. On Class B networks, connect the 3-SDU to the first CPU (sometimes called the service control unit). On 
Class A networks you can connect the 3-SDU to any node on the network. 

11. Click Download and Start to begin the network download. 

Upgrading firmware on 3-SSDC(1)(2)(C), 3-SDDC(1)(2)(C), and 3-AADC(1) loop controllers 
You must upgrade the 3-CPUxs before upgrading the loop controllers. 

You can upgrade the loop controllers using network downloads. 

If the bootstrap download fails, or if the steps are performed out of order, you must cycle the power on the control 
unit and restart the upgrade by downloading the bootstrap code again. 

You must complete each of the following steps in separate download sessions. 

To upgrade the loop controllers: 
1. Download the 3-SSDC(1)(2)/3-SDDC(1)(2)/3-AADC(1) bootstrap to each LRM. (Download the bootstrap only; 

do not download the application code or database.) 

2. From the LCD, issue a restart command for all control units. 

3. Download the 3-SSDC(1)(2)/3-SDDC(1)(2)/3-AADC(1) application code. 

4. Download the 3-SSDC(1)(2)/3-SDDC(1)(2)/3-AADC(1) loop controller databases. 

Upgrading the 3-ASU 
When upgrading the 3-ASU, we recommended that you do so in the following order: 

1. Download the boot code. 

2. Download the application code. 

3. Download the database. 
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Upgrading the CRC 
When upgrading the CRC/CRCXM, we recommend that you do so in the following order: 

1. Download the 3-SDU application code. 

2. Download the 3-SDU database. 

3. Download the ACDB database (from the CRC Administration tab, select the Destination DB Init task). 

Note: Upgrading the code to a CRC disables the access functionality for the door being controlled, until you use 
the ACDB to download its corresponding database. 

Upgrading from C-CPU 1.0x, 1.1x, 1.2x, V1.31 to 1.40 

Caution: If you have C-CPU V1.06 loaded in your control unit, you must upgrade to either V1.07 or V1.11, V1.20, 
V1.30 or V1.31, V1.40. 

Firmware V1.31 is not compatible with older databases (V1.0x firmware). The new application and all databases 
must be downloaded to all control units in the system. Do not mix different versions of C-CPU microcode on the 
same network; upgrade an existing system by carefully following these steps. 

Steps to upgrade the C-CPU to V1.40: 
1. Install 3-SDU 5.46. 

2. Click File > Open and select your project from the Open Project dialog box. Click OK to open the project. 

3. On the Project/Microcode tab, select the 1.40 version for C-CPU. 

4. Save your project as a new version, using the Save As command on the File menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop controllers and cabinets. 

7. Click File > Save to save the recompiled project. 

8. Click Tools > Communications and check Network for the download mode. 

9. Select the CPU Application code, bootstrap, C-CPU database, and the internal loop controller database (slot 
3) for each control unit.  

10. Connect your PC to any CPU node on the network.  

11. Click Download and Start to begin the network download. 

12. After the download finishes and the control units start up, the LCD shows the following internal fault: 

“xx000604Internal Fault”, where xx is the control unit address 

Restart the network to restore the fault. From any control unit in the network, select Program Menu > Restart 
and perform a restart of all control units. 

Downgrading the C-CPU from V1.40 to V1.xx 
You may want to downgrade a C-CPU version from V1.40 to 1.0x in certain situations.  

Caution: If your project includes zoned amplifiers that are impacted by the issue described in Tech Facts 16009, 
you must not use a version of C-CPU microcode earlier than V1.31. 

To downgrade the C-CPU version: 
1. Install 3-SDU 5.46.  

2. Click File > Open and select your project from the Open Project dialog box. Click OK to open the project. 
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3. On the Project/Microcode tab, select the 1.xx version for C-CPU. 

4. Save your project as a new version, using the Save As command on the File menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop controllers and cabinets. 

7. Click File > Save to save the recompiled project. 

8. Click Tools > Communications and check Network for the download mode. 

Select the C-CPU application code, the C-CPU database, and the internal loop controller database (slot 3) for 
each control unit.  

9. Connect your PC to any CPU node on the network.  

10. Click Download and Start to begin the network download. 

To upgrade a 3-PPS/M to a 4-PPS/M: 
When upgrading to the 4-PPS/M, we recommend that you do the following for each cabinet with the 4-PPS/M 
installed: 

1. Import the corresponding project.  

2. Click Configure > Cabinet, and then select the cabinet with the 4-PPS/M. 

3. Click the Modules tab, check the Downloadable 3-PS/M check box on the Hardware Layer tab, and then close 
the window. 

4. Click Rules > Compile, to recompile your project. 

5. Click Tools > DB Conversion > All Databases, to create all databases. 

6. Click Project > Save or Save As, to save the recompiled project. 

7. Click Tools > Communications, and then for Download Mode select Network. 

8. Download 3-CPUx Database. 

After the 3-CPU reboots, download 3-PS/M Bootstrap and Code. 

Important information 
When you open a 3-SDU project, you see a Warning message about missing or incompatible microcode versions. 
If you click OK, download the latest firmware and boot loader code before downloading the database. Without first 
downloading the application codes, the control unit may lock up. 

Figure 2: Missing or incompatible microcode versions warning 
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Reminder of NFPA 72 testing requirements 
When changes are made to site-specific software, the following shall apply: 

• All functions known to be affected by the change, or identified by a means that indicates changes, shall be 
tested 100 percent. 

• In addition, 10 percent of initiating devices that are not directly affected by the change, up to a maximum of  
50 devices, also shall be tested and correct system operation shall be verified. 

• A revised record of completion in accordance with NFPA standards shall be prepared to reflect these 
changes. 

• Changes to all control units connected or controlled by the system executive software shall require a  
10 percent functional test of the system, including a test of at least one device on each input and output circuit 
to verify critical system functions such as notification appliances, control functions, and off-premises reporting. 

Known issues 
The following known issues exist for 3-SDU 5.46. 

IP Dialer Email Service issue 
EST3X fire alarm control units configured for email services that deliver TCP/IP transmission of system events as 
email messages may experience non-transmission of messages from some email services in the control unit. No 
troubles are displayed on the control unit if this issue occurs, even when the Email Service is configured for 
supervision (Configure > Cabinet > IP Dialer - EMail > IP Services > Email Service > Email Service 
Configuration). 

For EST3X control units with an Email Service configured, use the following steps to determine if the service is 
functioning correctly. 

To verify TCP/IP email transmission: 
1. In the 3-SDU, configure a Time Control (Configure > Time Controls) to set a predefined time interval for 

sending the email messages.  

2. Write a rule to send emails using the Time Control configured above. 

3. If the emails are not received at the predefined time interval, restart the control unit. 

Windows 7 
Some features in the 3-SDU require you to run the program with higher privileges in the execution level scheme 
for Windows 7. However, when you run at the higher privilege level, the User Account Control dialog box appears. 
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Figure 3: User Account Control 

 

This appears because the 3-SDU is not currently certified with electronic signature verification software. Click 
Allow to run your 3-SDU with full functionality. 

Fonts and resolution 
You must run the 3-SDU on a computer with a resolution of 1024 x 768 or greater and use normal size fonts, that 
is, DPI setting: Normal size (96 DPI). If you use any other font setting the 3-SDU buttons may not be accessible. 

Using time controls to disable zone groups 
Members of a zone group are not disabled if the zone group is disabled via a time control. Do not use time 
controls to disable a zone group. 

Time synchronization 
3-CPU Version 03.10.00 has a known issue with the time synchronization command. If your system has Time 
Synchronization > System Time Source set to 3-LCD User Interface, then any communication with the 3-CPU will 
cause the system to reboot. We recommend that when you use 3-SDU 5.46 you set Time Synchronization > 
System Time Source to Input Circuit. 

R-Series remote annunciator group details 
The following functions for R-Series remote annunciators are not enabled at this time: 

• Matrix details 

• Service group details 

CDR-3 Bell Coder parity 
When using the CDR-3 on an EST3X fire alarm control unit (FACU), set the CDR-3 to “no parity” if you need 
extended digit operation. See the CDR-3 Bell Coder Installation Sheet (P/N 3100023) for details on the switch 
options. 
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AND group and matrix group queue state activations for device type changes 
When devices are added to AND groups or matrix groups the default queue state activation (Q1, Q2, Q3, Q4, NA 
(AND groups only)) for each device is set based on the device type. When you change the device type the queue 
state activation selection clears for all queue selections in the AND matrix groups. You must check each group 
and reselect the correct queue state activations based on the desired operations. 

Error message “File Access Denied” 
Updates have been made to the 3-SDU to address issues with saving, importing, and deleting projects using the 
configuration utility. If you continue to see File Access Denied error messages it may be related to the 3-SDU 
installation process. Windows 7 and later operating systems, do not allow any program to write to the root 
directory (C:\). If you have problems with locked files or if file access is denied we recommend reinstalling the  
3-SDU and allowing the Borland Database Engine to install in a folder other than the root directory. 

3-CPU RS232 Port 2 download issue at 38400 Baud 
When the serial port is configured as a printer on Port 1 and Gateway Type III (i.e. FireWorks) on Port 2, issues 
may occur when attempting to communicate to the control unit via Port 1. For example, when using the 3-SDU to 
communicate serially to the control unit using Port 1. Setting the baud rate for Port 1 to the same baud rate as 
Port 2 resolves this issue. 

Using an asterisk (*) symbol in 3-SDU object messages causes issues when importing OXP files into 
FireWorks 
FireWorks uses the asterisk symbol as a delimiter when importing object messages into the FireWorks system. 
To avoid possible issues we recommend that you do not use an asterisk in object messages. 

CDR-3 Bell Coder resetting of events 
Resetting events other than alarm events is not supported by the CDR-3. Only alarm events should be used for 
CDR-3 coder operations. 

Genesis common alarm NAC device types do not generate a warning during rules compile 
The 3-SDU Help topic “G_CommonAlarmOutput device type” incorrectly shows that Genesis common alarm 
output NAC device types (alarm, supervisory, and trouble) configured on a PS10-4B power supply will respond to 
the Disable command in correlations. The common alarm, supervisory, and trouble outputs will activate even 
when disabled. 

3-ANN series EVx annunciators require a 3-LCD or 3-LCDXL user interface 
An error occurs in the 3-SDU when converting a project database that includes an EVx 3-ANN series annunciator 
and when the system is configured without a 3-LCD user interface. The EVx 3-ANN series annunciators expect at 
least one 3-LCD or 3-LCDXL user interface to be configured in the system. 

Language selection combinations in the 3-SDU  
The 3-SDU allows mixed selections of primary and secondary languages that can create unique menus when 
viewed on the control unit LCD screen. For example, you can select Hebrew (Israel) for the primary language and 
English (USA) as the secondary language. Typically the US menu selection might show, “4) sig. device test” 
positioned on the left side of the LCD screen. However when you switch from the primary language (Hebrew 
(Israel)) to the alternate language (English (USA)) the LCD screen displays the menu as “sig. device test 4)” 
positioned on the right side of the LCD. All menus, commands, and reports executed from the control unit operate 
properly even though the menus display incorrectly on the LCD. 

Alternate message routing does not function for security events 
The 3-SDU 5.xx security events configured via the Activate menu as Alt Message Route or in the 3-SDU via a 
switch rule with the ALTMON output command, and on the 3-SDU Object Configuration, Msg Annunciation Route 
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Label as No_Msg_Annunciator_Groups_Route for all objects are displayed on the LCD screen, in error. The 
events are not displayed on the printer port, as expected. 

CPU database conversion error message “External response longer than 3000 bytes” 
The 3-SDU limits system programming and configuration so that the system functions properly. The error 
message “External response longer than 3000 bytes for device” appears when the configuration is outside system 
design capabilities.  

When the error message appears it indicates that too many output commands or outputs are qualified as part of 
the rule generating the error. To resolve the issues, we recommend: 

• Break up the rule into multiple rules with the same input and split the number of outputs between the rules. 

— or — 

• Configure command lists that are activated by the rule (preferred method). This is typically seen on an 
individual point programming basis. 

Note: New EST3X features in such as IP accounts and email services present the possibility of the error 
message being displayed as users push the limits of the design. For example, you might add eight cabinets to the 
system and select Auto Generate Events when configuring each IP account, which creates more than 75 IP 
accounts. To avoid the issue evaluate the number of IP accounts using Auto Generate Events. For example, 
determine if all accounts must auto-generate events, or if individual rules programming across multiple cabinets 
(requiring additional ETH cards) using similar CMS account numbers could be implemented.  

Incorrect personality code for CO devices 
The 3-SDU has been updated to detect invalid configuration settings for devices in the project database. During 
rules compile an error message displays for sensors that have incorrect personality codes. For example, “Invalid 
configuration: PHCOS device in Cab 1, Slot 4 Address 14 Personality 50 is not valid for COSetting of 
COSupervisory.”  

If the error message appears, change the personality code. 

To change the personality code: 
1. In the Cabinet Configuration dialog box, select the cabinet, and then click the Modules tab. 

2. Select the 3-SxDC1 loop controller where the CO device resides, and then click the LRM Config button. 

3. Click the Loop x Modules tab, and then find the device. 

4. Scroll to the Personality Code column and select the correct personality code from the list. 

5. Click close. 

SIGA-PHS common supervisory relay latches under some conditions involving sensor bypass 
When the SIGA-PHS device is configured for split supervisory/alarm operation the following sequence latches the 
supervisory relay (and any other rules based on the first supervisory response) in the ON state: 

Activate Sensor 
Activate SensorBypass 
Restore Sensor 
Restore SensorBypass 

To restore the latched supervisory relay (and anything that runs with first supervisory response), restart the 
control unit.  
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Communications error message “ie_NOpen - device not open” 
During communication between the control unit and the computer running the 3-SDU, the “ie_NOpen - device not 
open” error message may appear on the computer. This signifies that communication between the 3-SDU and 
control unit are not functioning properly. 

To restore communications: 
1. Close the 3-SDU, and then open it.  

If communication has not restored, go to step 2. 

2. Close the 3-SDU, reboot the computer, and then open the 3-SDU.  

If communication has not restored, go to step 3. 

3. Close the 3-SDU, reboot the computer, restart each control unit, and then open the 3-SDU. 

Barcode worksheet is not creating correct barcodes 
When printing the Signature Detectors/Modules Barcode Worksheet, the barcode may not generate correctly for 
some device addresses. Therefore when scanning a device’s address barcode the data may be incorrect, causing 
another device address to be selected in the Signature Series Configuration dialog box. 

To scan the correct device address barcode: 
1. In the Cabinet Configuration dialog box, select the cabinet, and then click the Modules tab. 

2. Select the 3-SxDC1 loop controller where the device resides, and then click the LRM Config button. 

3. Click the desired Loop x tab, and then find the device. 

4. Click the device address, and then scan the serial number barcode to input it. 

5. Click close. 

Email “Sent” time in the header field may not show correct local time 
For an EST3X FACU configured to generate emails, the event time in the email body may differ from the sent 
time that shows in the email header field and Sent filter for the received email. The email body contains the time 
and date stamps from the EST3X control unit (the local control unit time and date). The control unit cannot be 
configured to translate the sent time into your local time zone. 

Because the control unit does not support time zone configurations, emails sent from the control unit do not 
contain a time zone offset when generating the email format. The control unit uses −0000 for the time zone offset, 
meaning the time in the message format contains no information about time zone. Without the proper time zone 
offset the email send time may be interpreted as being sent using Coordinated Universal Time (UTC). (Refer to 
the Internet standard RFC 2822 Internet Message Format for details on date and time specifications.)  

Depending on the configuration of your email viewer and its view settings, the email message received from the 
control unit may not appear in the correct order for your time zone when your email is filtered to include Sent time. 
For example:  

You are located in the Eastern Time zone, and you configured the time zone on your device (cell phone, tablet, 
computer) to “(UTC −04:00) Eastern Time.” 

At 2:17 PM (14:17) Eastern Daylight Time (EDT) the control unit goes into trouble and an email is sent 
immediately. The email body shows the correct time and date stamp for the control unit location: 

“COMMON TRBL ACT 14:17:15 07/23/2015 P:01 C:03 D:0129 
Cab1_114 N_01_Slot_3_PULL_129” 

At 2:18 PM EDT your email server receives the message.  
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Your email viewer is filtered to display Received time, which shows the message was received at 2:18 PM. Your 
email viewer is also filtered to display Sent time, which shows the email was sent at 10:17 AM. 

Although the Sent time in your email viewer may appear to be incorrect, you can perform a simple calculation to 
confirm that it matches the email body. First, check your device’s configured time zone. In the example, it was set 
to UTC −4:00 EDT. Apply the calculation as follows:  

14:17 EDT (email body) − 04:00 hours = 10:17 AM (your email viewer) 

All active service group events display when not configured to display 
The Display Enabled list on the Configure > Cabinet > Options tab allows you to specify which events routed to 
the control unit you want the system to queue for display on the control unit. By default, the system will always 
display service group events when they go active whether you check the service group check box or not. 

Key Violation message appears when importing an audio clip file 
Do not import an audio clip file that has the same name as an existing file. Doing so may result in a “Key 
Violation” error message. If the error message appears, exit the audio tool, rename the file that you want to 
import, and then try to add the new clip (refer to the 3-SDU Help topic “Adding new audio clips”). If the issue 
persists, contact technical support. 

The Project Comparison Report does not show changes for message annunciation groups 
Because the Project Compare Utility does not compare message annunciation groups, no message annunciation 
group changes will appear in the Project Comparison Report. 

The Project Comparison Report does not show changes for KPDISP buzzer tones 
Because the Project Compare Utility does not compare KPDISP buzzer tones, no KPDISP buzzer tone changes 
will appear in the Project Comparison Report. 

Project files not completely deleting 
When you delete a currently open project (Project > Delete), the corresponding project folder may be locked, 
causing an error. To resolve this, close the 3-SDU to unlock the folder, and then reopen the utility. 

Root certificate is not found during database conversion 
For a project configured to use SSL encryption when transmitting system events using email SMTP servers, the 
database conversion may abort if the root certificate location has been changed from its configured location in an 
exported project. 

To avoid this issue, ensure that the certificate is located in the same directory location and folder as the computer 
from which the project was exported. We recommend that you always copy the certificate into the 3-SDU WORK 
folder.  

To configure the root certificate location: 
1. Open the project in the 3-SDU. 

2. Copy the root certificate (PEM or DER file) into the 3-SDU WORK folder. For example, C:\FAST\ 
3-SDU\WORK. 

3. Save the project. 

Changing the Device Type of an MCC2A or CC2A dual address module 
When changing the Device Type in the Modules tab on the Signature Series Configuration dialog box (Configure 
> Cabinet > Modules > 3-SxxC1 > LRM Config > Modules) for an MCC2A or CC2A dual address module, the 
Device Type for the second module does not automatically change. You must manually change the Device Type 
for both modules. 
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Preferred DNS address warning message 
For an EST3X FACU, when configuring the DHCP settings on the IP Configuration dialog box (Configure > 
Cabinet > IP Dialer - Email > IP Configuration), if you select “Use the following IP Address”, the 3-SDU 
automatically selects “Use the following DNS server address” in the DNS settings. If you try to close the 
configuration dialog box without changing the default Preferred DNS server address (0.0.0.0), a warning message 
appears requiring you to enter an address, as shown on page 23.  

 
A DNS server is only required if communicating to control units or other network devices by name. However, if the 
“Use the following DNS server addresses” option is selected, you must enter a non-zero address for the preferred 
DNS server in order to close the configuration dialog box.  

If your system does not require DNS communication, then enter any non-zero value as the Preferred DNS server 
address. For example, 8.8.8.8, which is Google’s public DNS server address. Click Close to exit the configuration 
dialog box. 

Downloadable 3-PS/M check box not described in 3-SDU 5.46 Help 
A “Downloadable 3-PS/M” check box now appears on the Cabinet Configuration > Modules tab. The check box 
has been included in 3-SDU 5.46 in advance of the release of the new Edwards 4-PPS/M power supply that will 
be a drop-in replacement of legacy 3-PPS/M, 3-BPS/M, and 3-BBC/M power supply modules. 

Checking the Downloadable 3-PS/M check box allows you to download microcode to the 4-PPS/M power supply.  

Note: For cabinets that have legacy 3-PPS/M, 3-BPS/M, or 3-BBC/M power supplies, when the Downloadable  
3-PS/M check box is checked and you attempt to download microcode a timeout message appears. 

To download microcode to the 4-PPS/M power supply: 
1. From the Configure menu, select Cabinet, and then select the cabinet with the 4-PPS/M. 

2. Click the Modules tab, check the Downloadable 3-PS/M check box on the Hardware Layer tab, and then close 
the window. 

3. From the Tools menu, select Communications. 

4. In the Action column: 

Click the 3-PS/M action box for Data Type > Code and select Download. 

Click the 3-PS/M action box for Data Type > Bootstrap and select Download. 
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5. Click Download/Upload. 

6. On the LRM Communications dialog box, click Start. 

3-SDU not returning to primary laptop monitor properties after using an external monitor 
When you use the 3-SDU with a monitor external from the primary laptop and then disconnect the external 
monitor, the 3-SDU may freeze.  

To reset the 3-SDU default window properties: 
1. Reconnect the external monitor, and then open the 3-SDU. 

2. Reset the 3-SDU default window properties: 

From the 3-SDU Options menu, select Customize, and then click the Behavior tab. 

Click Reset default window sizes & positions. 

— or — 

Open the Windows Task Manager, and then click the Processes tab. 

Select System Definition Utility, and then click End task. 

Revisions report displays 4-PPS/M microcode and hardware version numbers in legacy format 
The 4-PPS/M Revisions report on the control unit LCD screen will continue to use the same display format that 
was used for legacy 3-PPS/M,3-BPS/M, or 3-BBC/M power supplies. 

Example: 
APP: 04.00.10 
BOT: 01.00.00 
DB:  04.00.10  

Where, 
APP displays the microcode version number for the PSMON monitor card (.app microcode), 
BOT displays the PSMON’s hardware version, and 
DB displays the microcode version of the PPS mainboard (.bot microcode). 

 

 


